|
System Administration Commands | install(1M) |
| install - install commands |
SYNOPSIS
| /usr/sbin/install -c dira [-m mode] [-u user] [-g group] [-o] [-s] file |
| /usr/sbin/install -f dirb [-m mode] [-u user] [-g group] [-o] [-s] file |
| /usr/sbin/install -n dirc [-m mode] [-u user] [-g group] [-o] [-s] file |
| /usr/sbin/install -d | -i [-m mode] [-u user] [-g group] [-o] [-s] dirx ... |
| /usr/sbin/install [-m mode] [-u user] [-g group] [-o] [-s] file [dirx ...] |
|
install is most commonly used in ``makefiles'' (see make(1S)) to install a file in specific locations, or to create directories within a file system. Each file is installed by copying it into the appropriate
directory.
install uses no special privileges to copy files from one place to another. The implications of this are:
- You must have permission to read the files to be installed.
- You must have permission to copy into the destination directory.
- You must have permission to change the modes on the final copy of the file if you want to use the -m option.
- You must be super-user if you want to specify the ownership of the installed file with the -u or -g options. If you are not the super-user, the
installed file will be owned by you, regardless of who owns the original.
install prints messages telling the user exactly what files it is replacing or creating and where they are going.
If no options or directories (dirx ...) are given, install searches a set of default directories ( /bin, /usr/bin, /etc, /lib, and /usr/lib, in that order) for a file with the same name as file. When the first occurrence
is found, install issues a message saying that it is overwriting that file with file, and proceeds to do so. If the file is not found, the program states this and exits.
If one or more directories (dirx ...) are specified after file, those directories are searched before the default directories.
|
|
- -c dira
- Install file in the directory specified by dira, if file does not yet exist. If it is found, install issues a message saying that the file already exists, and exits without overwriting it.
- -f dirb
- Force file to be installed in given directory, even if the file already exists. If the file
being installed does not already exist, the mode and owner of the new file will be set to 755 and bin , respectively. If the file already exists,
the mode and owner will be that of the already existing file.
- -n dirc
- If file is not found in any of the searched directories, it is put in the directory specified
in dirc. The mode and owner of the new file will be set to 755 and bin, respectively.
- -d
- Create a directory. Missing parent directories are created as required as in mkdir -p. If the directory already
exists, the owner, group and mode will be set to the values given on the command line.
- -i
- Ignore default directory list, searching only through the given directories (dirx ...).
- -m mode
- The mode of the new file is set to mode. Set to 0755 by default.
- -u user
- The owner of the new file is set to user. Only available to the super-user. Set to bin by default.
- -g group
- The group id of the new file is set to group. Only available to the super-user. Set
to bin by default.
- -o
- If file is found, save the ``found'' file by copying it to OLDfile in the directory
in which it was found. This option is useful when installing a frequently used file such as /bin/sh or /lib/saf/ttymon, where the existing file cannot be removed.
- -s
- Suppress printing of messages other than error messages.
|
|
See largefile(5) for the description of the behavior
of install when encountering files greater than or equal to 2 Gbyte ( 231 bytes).
|
|
See attributes(5) for descriptions of the following
attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Availability | SUNWcsu |
|
| |