|
System Administration Commands | poolbind(1M) |
| poolbind - bind processes, tasks, or projects or query binding
of processes to resource pools |
SYNOPSIS
| /usr/sbin/poolbind -p poolname [ -i idtype] id ... |
| /usr/sbin/poolbind -q pid ... |
| /usr/sbin/poolbind -Q pid ... |
|
The poolbind command allows an authorized user to bind projects, tasks, and processes to pools. It can also allow a user to query a process to determine which pool the process is bound to.
|
|
The following options are supported:
- -i idtype
- This option, together with the idlist arguments, specifies one or more processes to which the poolbind command is to apply. The interpretation of idlist
depends on the value of idtype. The valid idtype arguments and corresponding interpretations of idlist are as follows:
-
pid
-
idlist is a list of process IDs. Binds the specified processes to the specified pool. This is the default behavior if no idtype is specified.
-
taskid
-
idlist is a list of task IDs. Bind all processes within the list of task IDs to the specified pool.
-
projid
-
idlist is a list of project IDs. Bind all processes within the list of projects to the specified pool. Each project ID can be specified as either a
project name or a numerical project ID. See project(4).
- -q pid ...
- Queries the pool bindings for a given list of process IDs. If the collection of resources associated with the process does not correspond to any currently existing pool, or if there are multiple
pools with the set of resources that the process is bound to, the query fails for that particular process ID.
- -Q pid ...
- Queries the resource bindings for a given list of process IDs. The resource bindings are each reported on a separate line.
|
|
The following operands are supported:
-
poolname
- The name of a pool to which the specified project, tasks or processes are to be bound.
|
| Example 1. Binding All Processes
|
The following command binds all processes in projects 5 and 7 to pool web_app:
|
example# /usr/sbin/poolbind -p web_app -i projid 5 7
|
|
Example 2. Binding the Running Shell
|
The following command binds the running shell to pool web_app:
|
example# /usr/sbin/poolbind -p web_app $$
|
|
Example 3. Querying the Pool Bindings
|
The following command queries the bindings to verify that the shell is bound to the given pool:
|
example# /usr/sbin/poolbind -q $$
|
|
Example 4. Querying the Resource Bindings
|
The following command queries the bindings to verify that the shell is bound to the given resources:
|
example# /usr/sbin/poolbind -Q $$
|
|
|
|
The following exit values are returned:
-
0
- Successful completion.
-
1
- Requested operation could not be completed.
-
2
- Invalid command line options were specified.
|
|
See attributes(5) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Availability | SUNWpool |
Interface Stability Invocation Output | Evolving Unstable |
|
| |