|
System Administration Commands | psrinfo(1M) |
| psrinfo - displays information about processors |
SYNOPSIS
| psrinfo [-v] [processor_id ...] |
|
psrinfo displays information about processors.
Without the processor_id operand, psrinfo displays one line for each configured processor, displaying whether it is on-line, non-interruptible (designated by no-intr), off-line, or powered off, and when that status last changed. Use
the processor_id operand to display information about a specific processor. See OPERANDS.
|
|
The following options are supported:
- -s processor_id
- Silent mode. Displays 1 if the specified processor is fully on-line, and 0 if the specified processor is non-interruptible, off-line, or powered off.
Use silent mode when using psrinfo in shell scripts.
- -v
- Verbose mode. Displays additional information about the specified processors, including: processor type, floating point unit type and clock speed. If any of this information cannot be determined, psrinfo displays unknown.
|
|
The following operands are supported:
-
processor_id
- The processor ID of the processor about which information is to be displayed.
Specify processor_id as an individual processor number (for example, 3), multiple processor numbers separated by spaces (for example, 1 2 3), or a range of processor numbers (for example, 1-4). It is also possible
to combine ranges and (individual or multiple) processor_ids (for example, 1-3 5 7-8 9).
|
| Example 1. Displaying Information About All Configured Processors in Verbose Mode
|
The following example displays information about all configured processors in verbose mode.
|
Example 2. Determining If a Processor is On-line
|
The following example uses psrinfo in a shell script to determine if a processor is on-line.
|
if [ "`psrinfo -s 3 2> /dev/null`" -eq 1 ]
then
echo "processor 3 is up"
fi
|
|
|
|
The following exit values are returned:
-
0
- Successful completion.
-
>0
- An error occurred.
|
|
See attributes(5) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Availability | SUNWcsu |
|
|
-
psrinfo: processor 9: Invalid argument
- The specified processor does not exist.
|
| |