|
System Administration Commands | removef(1M) |
| removef - remove a file from software database |
SYNOPSIS
| removef [ [-M] -R root_path] [-V fs_file] pkginst path ... |
| removef [ [-M] -R root_path] [-V fs_file] -f pkginst |
|
removef informs the system that the user, or software, intends to remove a pathname. Output from removef is the list of input pathnames that may be safely removed (no other packages
have a dependency on them).
|
|
The following options are supported:
- -f
- After all files have been processed, removef should be invoked with the -f option to indicate that the removal phase is complete.
- -M
- Instruct removef not to use the $root_path/etc/vfstab file for determining the client's mount points. This option assumes the mount points are correct on the
server and it behaves consistently with Solaris 2.5 and earlier releases.
-
-R root_path
- Define the full path name of a directory to use as the root_path. All files, including package system information files, are relocated to a directory tree starting
in the specified root_path. The root_path may be specified when installing to a client from a server (for example, /export/root/client1).
- -V fs_file
- Specify an alternative fs_file to map the client's file systems. For example, used in situations where the $root_path/etc/vfstab file is non-existent or unreliable.
|
|
The following operands are supported:
-
path
- The pathname to be removed.
-
pkginst
- The package instance from which the pathname is being removed.
|
| Example 1. Using removef
|
The following example uses the removef command in an optional pre-install script:
|
echo "The following files are no longer part of this package
and are being removed."
removef $PKGINST /dev/xt[0-9][0-9][0-9] |
while read pathname
do
echo "$pathname"
rm -f $pathname
done
removef -f $PKGINST || exit 2
|
|
|
|
-
0
- Successful completion.
-
>0
- An error occurred.
|
|
See attributes(5) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Availability | SUNWcsu |
|
| |