Sun Microsystems, Inc.
spacerspacer
spacer   www.sun.com docs.sun.com | | |  
spacer
black dot
   
A   B   C   D   E   F   G   H   I   J   K   L   M   N   O   P   Q   R   S   T   U   V   W   X   Y   Z
    
 
System Administration Commandssacadm(1M)


NAME

 sacadm - service access controller administration

SYNOPSIS

 sacadm -a -p pmtag -t type -c cmd -v ver [ -f dx] [-n count] [-y comment] [-z script]
 sacadm -r -p pmtag
 sacadm -s -p pmtag
 sacadm -k -p pmtag
 sacadm -e -p pmtag
 sacadm -d -p pmtag
 sacadm -l [ -p pmtag | -t type]
 sacadm -L [ -p pmtag | -t type]
 sacadm -g -p pmtag [-z script]
 sacadm -G [-z script]
 sacadm -x [-p pmtag]

DESCRIPTION

 

sacadm is the administrative command for the upper level of the Service Access Facility hierarchy (port monitor administration). sacadm performs the following functions:

  • adds or removes a port monitor
  • starts or stops a port monitor
  • enables or disables a port monitor
  • installs or replaces a per-system configuration script
  • installs or replaces a per-port monitor configuration script
  • prints requested port monitor information

Requests about the status of port monitors (-l and -L) and requests to print per-port monitor and per-system configuration scripts (-g and -G without the -z option) may be executed by any user on the system. Other sacadm commands may be executed only by the super-user.

OPTIONS

 
-a
Add a port monitor. When adding a port monitor, sacadm creates the supporting directory structure in /etc/saf and /var/saf and adds an entry for the new port monitor to /etc/saf/_sactab. The file _sactab already exists on the delivered system. Initially, it is empty except for a single line, which contains the version number of the Service Access Controller. Unless the command line that adds the new port monitor includes the -f option with the -x argument, the new port monitor will be started. Because of the complexity of the options and arguments that follow the - a option, it may be convenient to use a command script or the menu system to add port monitors.
-c cmd
Execute the command string cmd to start a port monitor. The -c option may be used only with a -a. A -a option requires a -c.
-d
Disable the port monitor pmtag.
-e
Enable the port monitor pmtag.
-f dx
The -f option specifies one or both of the following two flags which are then included in the flags field of the _sactab entry for the new port monitor. If the -f option is not included on the command line, no flags are set and the default conditions prevail. By default, a port monitor is started. A -f option with no following argument is illegal.
d
Do not enable the new port monitor.
x
Do not start the new port monitor.
-g
The -g option is used to request output or to install or replace the per-port monitor configuration script /etc/saf/pmtag/_config. -g requires a -p option. The -g option with only a -p option prints the per-port monitor configuration script for port monitor pmtag. The -g option with a -p option and a -z option installs the file script as the per-port monitor configuration script for port monitor pmtag. Other combinations of options with -g are invalid.
-G
The -G option is used to request output or to install or replace the per-system configuration script /etc/saf/_sysconfig. The -G option by itself prints the per-system configuration script. The -G option in combination with a -z option installs the file script as the per-system configuration script. Other combinations of options with a -G option are invalid.
-k
Stop port monitor pmtag.
-l
The -l option is used to request port monitor information. The -l by itself lists all port monitors on the system. The -l option in combination with the -p option lists only the port monitor specified by pmtag. A -l in combination with the -t option lists all port monitors of type type. Any other combination of options with the -l option is invalid.
-L
The -L option is identical to the -l option except that the output appears in a condensed format.
-n count
Set the restart count to count. If a restart count is not specified, count is set to 0. A count of 0 indicates that the port monitor is not to be restarted if it fails.
-p pmtag
Specifies the tag associated with a port monitor.
-r
Remove port monitor pmtag. sacadm removes the port monitor entry from /etc/saf/_sactab. If the removed port monitor is not running, then no further action is taken. If the removed port monitor is running, the Service Access Controller (SAC) sends it SIGTERM to indicate that it should shut down. Note that the port monitor's directory structure remains intact.
-s
Start a port monitor. The SAC starts the port monitor pmtag.
-t type
Specifies the port monitor type.
-v ver
Specifies the version number of the port monitor. This version number may be given as
 
-v `pmspec -V`
where pmspec is the special administrative command for port monitor pmtag. This special command is ttyadm for ttymon and nlsadmin for listen. The version stamp of the port monitor is known by the command and is returned when pmspec is invoked with a -V option.
-x
The -x option by itself tells the SAC to read its database file (_sactab). The -x option with the -p option tells port monitor pmtag to read its administrative file.
-y comment
Include comment in the _sactab entry for port monitor pmtag.
-z script
Used with the -g and -G options to specify the name of a file that contains a configuration script. With the -g option, script is a per-port monitor configuration script; with -G it is a per-system configuration script. Modifying a configuration script is a three-step procedure. First a copy of the existing script is made (-g or -G). Then the copy is edited. Finally, the copy is put in place over the existing script (-g or -G with -z).

OUTPUT

 

If successful, sacadm will exit with a status of 0. If sacadm fails for any reason, it will exit with a nonzero status. Options that request information will write the information on the standard output. In the condensed format (-L), port monitor information is printed as a sequence of colon-separated fields; empty fields are indicated by two successive colons. The standard format (-l) prints a header identifying the columns, and port monitor information is aligned under the appropriate headings. In this format, an empty field is indicated by a hyphen. The comment character is #.

EXAMPLES

 Example 1. A sample output of the sacadm command.
 

The following command line adds a port monitor. The port monitor tag is npack; its type is listen; if necessary, it will restart three times before failing; its administrative command is nlsadmin; and the configuration script to be read is in the file script:

 
sacadm -a -p npack -t listen -c /usr/lib/saf/listen npack
-v `nlsadmin -V` -n 3 -z script

Remove a port monitor whose tag is pmtag:

 
sacadm -r -p pmtag

Start the port monitor whose tag is pmtag:

 
sacadm -s -p pmtag

Stop the port monitor whose tag is pmtag:

 
sacadm -k -p pmtag

Enable the port monitor whose tag is pmtag:

 
sacadm -e -p pmtag

Disable the port monitor whose tag is pmtag:

 
sacadm -d -p pmtag

List status information for all port monitors:

 
sacadm -l

List status information for the port monitor whose tag is pmtag:

 
sacadm -l -p pmtag

List the same information in condensed format:

 
sacadm -L -p pmtag

List status information for all port monitors whose type is listen:

 
sacadm -l -t listen

Replace the per-port monitor configuration script associated with the port monitor whose tag is pmtag with the contents of the file file.config:

 
sacadm -g -p pmtag -z file.config

FILES

 
/etc/saf/_sactab
/etc/saf/_sysconfig
/etc/saf/pmtag/_config

ATTRIBUTES

 

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPEATTRIBUTE VALUE
AvailabilitySUNWcsu

SEE ALSO

 

pmadm(1M), sac(1M), doconfig(3NSL), attributes(5)


SunOS 5.9Go To TopLast Changed 14 Sep 1992

 
      
      
Copyright 2002 Sun Microsystems, Inc. All rights reserved. Use is subject to license terms.