|
System Administration Commands | smdiskless(1M) |
| smdiskless - manage diskless client support for a server |
SYNOPSIS
| /usr/sadm/bin/smdiskless subcommand [ auth_args] -- [subcommand_args] |
|
The smdiskless command manages diskless client support for a server.
smdiskless subcommands are:
-
add
- Adds a new diskless client to a server. There are two usages for this command. The user can either specify all the optional arguments directly on the command line, or provide a sysidcfg(4) formatted file as input. A future enhancement will allow specifying both a sysidcfg(4) formatted file and optional arguments, which will
override the values in the sysidcfg(4) file.
-
delete
- Deletes an existing diskless client from the system databases and removes any server support associated with the host, depending on the os_server type.
-
list
- Lists existing diskless clients served by os_server.
-
modify
- Modifies the specified attributes of the diskless client os_server.
|
|
The smdiskless authentication arguments, auth_args, are derived from the smc(1M) arg set and are the same regardless of which subcommand you
use. The smdiskless command requires the Solaris Management Console to be initialized for the command to succeed (see smc(1M)). After rebooting the Solaris Management Console
server, the first Solaris Management Console connection might time out, so you might need to retry the command.
The subcommand-specific options, subcommand_args, must come after the auth_args and must be separated from them by the -- option.
auth_args
|
The valid auth_args are -D, -H, -l, -p, -r, and -u; they are all optional. If no auth_args are specified, certain defaults will be assumed and the
user may be prompted for additional information, such as a password for authentication purposes. These letter options can also be specified by their equivalent option words preceded by a double dash. For example, you can use either -D or --domain.
Note smdiskless supports the --auth-data file option, which enables you to specify a file the console can read to collect authentication data. See smc(1M) for a description of this option.
- -D | --domain domain
- Specifies the default domain that you want to manage. The syntax of domain is type:/host_name/domain_name, where type is nis, nis+, dns, ldap, or file; host_name is the name of the machine that serves the
domain; and domain_name is the name of the domain you want to manage. (Note: Do not use nis+ for nisplus.)
If you do not specify this option, the Solaris Management Console assumes the file default domain on whatever server you choose to manage, meaning that changes are local to the server. Toolboxes can change the domain on a tool-by-tool basis; this option specifies the domain for
all other tools.
- -H | --hostname host_name:port
- Specifies the host_name and port to which you want to connect. If you do not specify a port, the system connects to the default port, 898. If you do not specify host_name:port, the Solaris Management Console connects to the local host on port 898. You may still have to choose a toolbox to load into the console.
To override this behavior, use the smc(1M) -B option, or set your console preferences to load a "home toolbox" by default.
- -l | --rolepassword role_password
- Specifies the password for the role_name. If you specify a role_name but do not specify a role_password, the system prompts you to supply a role_password. Passwords specified on the command line can be seen by any user on the system, hence this option is considered insecure.
- -p | --password password
- Specifies the password for the user_name. If you do not specify a password, the system prompts you for one. Passwords specified
on the command line can be seen by any user on the system, hence this option is considered insecure.
- -r | --rolename role_name
- Specifies a role name for authentication. If you do not specify this option, no role is assumed.
- -u | --username user_name
- Specifies the user name for authentication. If you do not specify this option, the user identity running the console process is assumed.
- --
- This option is required and must always follow the preceding options. If you do not enter the preceding options, you must still enter the -- option.
|
subcommand_args
|
Note: Descriptions and other arg options that contain white spaces must be enclosed in double quotes.
- For subcommand add:
- -h
- (Optional) Displays the command's usage statement.
- -i IP_address
- Specifies the IP address for the host in the form of 129.9.200.1.
- -e ethernet_addr
- Specifies the Ethernet address.
- -n host
- Specifies the client name.
- -o os_server
- (optional) Specifies the name of the host where the OS service filesystems reside. If this option is not specified, the host will be the same as that specified in the smc(1M) -D option. This option is useful in the event that the name service server and the OS server are not the same machine.
- -x os=platform
- Specifies the operating system. The syntax for platform is as follows:
instruction_set.implementation.Solaris_version
where
-
instruction_set is one of sparc or i386
-
implementation is the implementation architecture, that is, i86pc, sun4c (for Solaris 2.6 and 7 only), sun4m, and sun4u.
-
version is the Solaris version number. The supported version numbers are 2.6, 2.7 (for Solaris 7), 8, and 9. Examples are:
|
sparc.sun4c.Solaris_2.7
sparc.sun4u.Solaris_8
|
- -x root=pathname
- (Optional) Specifies the absolute path of the directory in which to create the root directory for diskless clients. The default (and recommended) pathname is /export/root/client_name.
- -x swap=pathname
- (Optional) Specifies the absolute path of the directory in which to create the swap file for diskless clients. The default (and recommended) pathname is /export/swap/client_name.
- -x swapsize=size
- (Optional) Specifies the size, in megabytes, of the swap file for diskless clients. The default swap size is 24M.
- -x dump=pathname
- (Optional) Specifies the absolute path of the dump directory for diskless clients. The default (and recommended) pathname is /export/dump/client_name.
- -x dumpsize=size
- (Optional) Specifies the size, in megabytes, of the dump file for diskless clients. The default swap size is 24M.
- -x pw=Y
- (Optional) Prompts for the system's root password. The default is not to prompt.
The following options are used to configure workstations on first boot by sysidtool(1M). They can either be specified on the command line, or in a sysidcfg(4) formatted file. Note: Use the sysidcfg(4) file to:
- Add a DNS client.
- Specify use of the LDAP name service.
- Specify a security policy.
The keywords and functions supported by sysidtool and sysidcfg vary among Solaris releases. Consult the man pages for your operating system release (uname -r) to determine the level of support available.
- -x tz=timezone
- (Optional) Specifies the path of a timezone file, relative to /usr/share/lib/zoneinfo. The default is the server's timezone.
- -x ns=NIS | NIS+ | NONE
- (Optional) Specifies the client's nameservice. This is one of NIS, NIS+, or NONE . Use a sysidcfg(4) file to specify DNS or LDAP. The default ns value is NONE, which results in the use of the files source in nsswitch.conf. See nsswitch.conf(4) for a description of the files source.
- -x nameserver=hostname
- (Optional) Specifies the nameserver's hostname. The default is the server's nameserver.
- -x domain=domain
- (Optional) Specifies the client's domain. The default is the server's domain.
- -x nameserver_ipaddress=ip_address
- (Optional) Specifies the nameserver's IP address.
- -x netmask=ip_address
- (Optional) Specifies the client's IP address netmask. The default is the server's netmask.
- -x locale=locale
- (Optional) Specifies the client's system locale. The default is the C locale.
- -x terminal=term
- (Optional) Specifies the workstation's terminal type, typically, sun or xterms.
- -x passwd=root_password
- (Optional) Specifies the system's root password. The default is no password.
- -x sysidcfg=path_to_sysidcfg_file
- (Optional) Specifies the file to be placed in the /etc directory of the diskless client. On first boot, /etc/.UNCONFIGURED exists and sysidtool(1M) will run. If a file called /etc/sysidcfg exists, sysidtool(1m) reads this file and uses the information for system
configuration.
- For subcommand delete:
- -h
- (Optional) Displays the command's usage statement.
- -n host
- Specifies the hostname of the diskless client to delete. This host is deleted from relevant tables and OS Services for this client are deleted.
- -o os_server
- (Optional) Specifies the name of the host where the OS service filesystems reside. If this option is not specified, the host will be the same as that specified in the smc(1M) -D option. This option is useful in the event that the name service server and the OS server are not the same machine.
- For subcommand list:
- -h
- (Optional) Displays the command's usage statement.
- -o os_server
- (Optional) Specifies the name of the host where the OS service filesystems reside. If this option is not specified, the host will be the same as that specified in the smc(1M) -D option. This option is useful in the event that the name service server and the OS server are not the same machine.
- For subcommand modify:
- -e ethernet_addr
- Changes the specified diskless client's ethernet address to ethernet_addr.
- -h
- (Optional) Displays the command's usage statement.
- -n host
- Specifies the host name of the diskless client to modify.
- -o os_server
- (Optional) Specifies the name of the host where the OS service filesystems reside. If this option is not specified, the host will be the same as that specified in the smc(1M) -D option. This option is useful in the event that the name service server and the OS server are not the same machine.
- -x tz=timezone
- (Optional) Changes the specified diskless client's timezone.
|
|
| Example 1. Creating a new diskless client
|
The following command adds a new diskless client named client1 which will run Solaris 9 on a sun4u machine:
|
example% /usr/sadm/bin/smdiskless add -- -i 129.9.200.1 \
-e 8:0:11:12:13:14 -n client1 -x os=sparc.sun4u.Solaris_9 \
-x root=/export/root/client1 -x swap=/export/swap/client1 \
-x swapsize=32 -x tz=US/Eastern -x locale=en_US
|
|
Example 2. Deleting an existing diskless client
|
The following command deletes the diskless client named client1 from the OS server named osserver, where the OS server is using NIS+ and the NIS+ server is nisplusserve:
|
example% /usr/sadm/bin/smdiskless delete \
-D nisplus:/nisplusserver/my.domain.com -- \
-o osserver -n client1
|
|
Example 3. Listing the diskless clients served by a host
|
The following command lists the diskless clients running on the OS server, osserver:
|
example% /usr/sadm/bin/smdiskless list -D file:/osserver/osserver -- \
-o osserver
|
|
Example 4. Modifying the attributes of the diskless client host
|
The following command modifies the ethernet address for the client named client1 on the OS server, osserver, to be 8:0:11:12:13:15:
|
example% /usr/sadm/bin/smdiskless modify -D file:/osserver/osserver -- \
-o osserver -n client1 -e 8:0:11:12:13:15
|
|
|
|
See environ(5) for a description of the JAVA_HOME environment variable, which affects the execution of the smdiskless command.
If this environment variable is not specified, the /usr/java1.2 location is used. See smc(1M).
|
|
The following exit values are returned:
-
0
- Successful completion.
-
1
- Invalid command syntax. A usage message displays.
-
2
- An error occurred while executing the command. An error message displays.
|
|
See attributes(5) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Availability | SUNWdclnt |
|
| |