|
System Administration Commands | smmaillist(1M) |
| smmaillist - manage email alias
entries |
SYNOPSIS
| /usr/sadm/bin/smmaillist subcommand [ auth_args] -- [subcommand_args] |
|
The smmaillist command manages one or more email alias entries for the appropriate files in the local /etc files name service or a NIS or NIS+ name service.
subcommands
|
smmaillist subcommands are:
-
add
- Creates a new email alias definition and adds it to the appropriate files. To add an entry, the administrator must have the solaris.admin.usermgr.write authorization.
-
delete
- Deletes an email alias entry. You can delete only one entry at a time. To delete an entry, the administrator must have the solaris.admin.usermgr.write authorization. Note: You cannot delete
Postmaster or Mailer-Daemon aliases.
-
list
- Lists one or more email alias entries. To list an entry, the administrator must have the solaris.admin.usermgr.read authorization.
-
modify
- Modifies an email alias entry. To modify an entry, the administrator must have the solaris.admin.usermgr.write authorization.
|
|
|
The smmaillist authentication arguments, auth_args, are derived from the smc(1M) arg set and are the same regardless of which subcommand you
use. The smmaillist command requires the Solaris Management Console to be initialized for the command to succeed (see smc(1M)). After rebooting the Solaris Management Console
server, the first Solaris Management Console connection might time out, so you might need to retry the command.
The subcommand-specific options, subcommand_args, must come after the auth_args and must be separated from them by the -- option.
auth_args
|
The valid auth_args are -D, -H, -l, -p, -r, and -u; they are all optional. If no auth_args are specified, certain defaults will be assumed and the
user may be prompted for additional information, such as a password for authentication purposes. These letter options can also be specified by their equivalent option words preceded by a double dash. For example, you can use either -D or --domain with the domain argument.
- -D | --domain domain
- Specifies the default domain that you want to manage. The syntax of domain is type:/host_name/domain_name, where type is nis, nisplus, dns, ldap, or file; host_name is the name of the machine that serves the
domain; and domain_name is the name of the domain you want to manage. (Note: Do not use nis+ for nisplus.)
If you do not specify this option, the Solaris Management Console assumes the file default domain on whatever server you choose to manage, meaning that changes are local to the server. Toolboxes can change the domain on a tool-by-tool basis; this option specifies the domain for
all other tools.
- -H | --hostname host_name:port
- Specifies the host_name and port to which you want to connect. If you do not specify a port, the system connects to the default port, 898. If you do not specify host_name:port, the Solaris Management Console connects to the local host on port 898. You may still have to choose a toolbox to load into
the console. To override this behavior, use the smc(1M) -B option, or set your console preferences to load a "home toolbox" by default.
- -l | --rolepassword role_password
- Specifies the password for the role_name. If you specify a role_name but do not specify a role_password, the system prompts you to supply a role_password. Passwords specified on the command line can be seen by any user on the system, hence this option is considered insecure.
- -p | --password password
- Specifies the password for the user_name. If you do not specify a password, the system prompts you for one. Passwords specified
on the command line can be seen by any user on the system, hence this option is considered insecure.
- -r | --rolename role_name
- Specifies a role name for authentication. If you do not specify this option, no role is assumed.
- -u | --username user_name
- Specifies the user name for authentication. If you do not specify this option, the user identity running the console process is assumed.
- --
- This option is required and must always follow the preceding options. If you do not enter the preceding options, you must still enter the -- option.
|
subcommand_args
|
Note: Descriptions and other arg options that contain white spaces must be enclosed in double quotes.
- For subcommand add:
- -a address1 -a address2 . . .
- (Optional) Specifies the new email address. See sendmail(1M).
- -h
- (Optional) Displays the command's usage statement.
- -n alias_name
- Specifies the name of the alias you want to add. See sendmail(1m).
- For subcommand delete:
- -h
- (Optional) Displays the command's usage statement.
- -n alias_name
- Specifies the alias you want to delete.
- For subcommand list:
- -h
- (Optional) Displays the command's usage statement.
- -n alias_name
- (Optional) Specifies the name of the alias you want to display. If you do not specify an alias, all aliases are listed.
- For subcommand modify:
- -a address1 -a address2 . . .
- (Optional) Specifies new email address(es) to replace the existing one(s). See sendmail(1M).
- -h
- (Optional) Displays the command's usage statement.
- -n alias_name
- (Optional) Specifies the name of the alias you want to modify.
- -N new_alias_name
- Specifies the new alias name. Use only when renaming an alias. See sendmail(1m).
|
|
| Example 1. Creating an alias
|
The following creates the coworkers alias and adds the following member list: bill@machine1, sue@machine2, and me@machine3 to the alias.
|
./smmaillist add -H myhost -p mypasswd -u root -- -n coworkers \
-a bill@machine1 -a sue@machine2 -a me@machine3
|
|
Example 2. Deleting a mail alias
|
The following deletes the my_alias alias:
|
./smmaillist delete -H myhost -p mypasswd -u root -- -n my_alias
|
|
Example 3. Displaying members of a mail alias
|
The following displays the list of members belonging to the my_alias alias:
|
./smmaillist list -H myhost -p mypasswd -u root -- -n my_alias
|
|
Example 4. Displaying members of all mail aliases
|
The following displays the list of members belonging to all mail aliases:
|
./smmaillist list -H myhost -p mypasswd -u root --
|
|
Example 5. Renaming a mail alias
|
The following renames the current_name mail alias to new_name:
|
./smmaillist modify -H myhost -p mypasswd -u root -- \
-n current_name -N new_name
|
|
Example 6. Redefining an address list
|
The following changes the recipients of the alias my_alias to bill@machine1. Any previous recipients are deleted from the alias.
|
./smmaillist modify -H myhost -p mypasswd -u root -- \
-n my_alias -a bill@machine1
|
|
|
|
See environ(5) for a description of the JAVA_HOME environment variable, which affects the execution of the smmaillist command.
If this environment variable is not specified, the /usr/java location is used. See smc(1M).
|
|
The following exit values are returned:
-
0
- Successful completion.
-
1
- Invalid command syntax. A usage message displays.
-
2
- An error occurred while executing the command. An error message displays.
|
|
The following files are used by the smmaillist command:
-
/var/mail/aliases
- Aliases for sendmail(1M). See aliases(4).
|
|
See attributes(5) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Availability | SUNWmga |
|
| |