|
System Administration Commands | ssaadm(1M) |
| ssaadm - administration program for SPARCstorage Array and SPARCstorage RSM disk systems |
SYNOPSIS
| ssaadm [-v] [-e] subcommand [subcommand_option ...] | pathname ... |
|
The ssaadm program is an administrative command that manages the SPARCstorage Array and SPARCstorage RSM disk systems (henceforth called SPARCstorage systems). ssaadm performs a variety of control and query tasks depending on the command line arguments and options used.
The command line must contain a subcommand (listed under USAGE) and at least one pathname. Commands specific to either a SPARCstorage Array or a SPARCstorage RSM state that fact. It may also
contain options and other parameters depending on the subcommand. The subcommand is applied to each of the pathnames on the command line.
pathname specifies the SPARCstorage system controller or a disk in the SPARCstorage system. The controller name is specified by its physical name, for example,
|
/devices/.../.../SUNW,soc@3,0/SUNW,
pln@axxxxxxx,xxxxxxxx:ctlr
|
or by a name of the form
cN
where N is the logical controller number. ssaadm uses the cN name to find an entry in the /dev/rdsk directory of a disk that is attached to the SPARCstorage system controller. The /dev/rdsk entry is then used to determine the physical name of the SPARCstorage system controller. A disk in the SPARCstorage system is specified by its logical or physical device name, for example,
or
|
/devices/.../.../SUNW,soc@3,0/SUNW,
pln@axxxxxxx,xxxxxxxx/ssd@0,0:c,raw
|
See disks(1M) for more information on logical names for disks and controllers.
|
|
The following options are supported:
- -e
- Expert mode. This is required for the expert mode subcommands listed below.
- -v
- Verbose mode.
Subcommands and their options are described below. Expert mode subcommands are listed separately.
|
|
The following operands are supported:
-
pathname
- The SPARCstorage system controller or a disk in the SPARCstorage system.
|
|
Subcommands
|
-
display [-p] pathname...
- Display configuration information for the specified units or display performance information for the specified SPARCstorage Array controller.
If pathname specifies the controller, the configuration information is displayed for all disks in the SPARCstorage Array. For each drive that has fast write enabled, (FW) are displayed after the drive identification.
- -p
- Display performance information for the specified SPARCstorage Array controller. The accumulation of the performance statistics must be enabled using the perf_statistics subcommand before displaying the performance
information. If not enabled, all of the I/Os per second are displayed as zeros.
The performance display reports the following information:
-
BUSY
- How busy the controller in the SPARCstorage Array is, expressed as a percentage.
-
IOPS
- The total I/Os per second for the SPARCstorage Array.
- entries for each disk
- The total number of I/Os per second.
-
download -f filename pathname
-
download -w wwn pathname
- Download an image
to the SPARCstorage Array controller.
- -f
- Download the prom image specified by filename to the SPARCstorage Array controller FEPROMs. When the download is complete, the SPARCstorage Array must be reset in order to use the downloaded
code. Note that the download subcommand modifies the FEPROM on the SPARCstorage Array and should be used with caution.
- -w
- Change the SPARCstorage Array controller's World Wide Name. wwn is a 12 digit hex number, leading zeros required. The new SPARCstorage Array controller's image have the least significant 6 bytes of the 8-byte World
Wide Name modified to wwn.
-
fast_write [-s] -c pathname
-
fast_write [-s] -d pathname
-
fast_write [-s] -e pathname
- Enable or disable the use of the NVRAM to enhance the performance of writes in the SPARCstorage Array. pathname may refer to the SPARCstorage Array controller or to an individual
disk.
- -c
- Enable fast writes for synchronous writes only.
- -d
- Disable fast writes.
- -e
- Enable fast writes.
- -s
- Save the state that is currently being requested so it persists across power-cycles.
-
fc_s_download [-f fcode-file]
- Download the fcode contained in the file fcode-file into all the FC/S Sbus Cards.
This subcommand is interactive and expects user confirmation before downloading the fcode. When invoked without the [-f fcode-file] option, the current version of the fcode in each FC/S Sbus card is printed. Note that the fc_s_download subcommand should be used only in single-user mode; otherwise the FC/S card could be reset.
-
insert_device pathname
- Guide user through hot insertion of a disk device.
This subcommand only applies to the RSM. See NOTES for hot plugging limitations.
-
perf_statistics -d pathname
-
perf_statistics -e pathname
- Enable or disable the accumulation of performance statistics for the
specified SPARCstorage Array controller. The accumulation of performance statistics must be enabled before using the display -p subcommand. This subcommand can be issued only to the SPARCstorage Array controller.
- -d
- Disable the accumulation of performance statistics.
- -e
- Enable the accumulation of performance statistics.
-
purge pathname
- Purge any fast write data from NVRAM for one disk, or all disks if the controller is specified. This option should be used with caution, usually only when a drive has
failed.
-
release pathname
- Release a reservation held on the specified controllers or disks. When HA (High_Availability) Software is running on a system, do not use this subcommand to release
a disk on an SSA. Doing so could cause problems for the HA software.
-
remove_device pathname
- Guide user through hot removal of a disk device.
This subcommand only applies to the RSM. See NOTES for hot plugging limitations.
-
replace_device pathname
- Guide user through hot replacement of a disk device.
This subcommand only applies to the RSM. See NOTES for hot plugging limitations.
-
reserve pathname
- Reserve the specified controllers or disks for exclusive use by the issuing host. When HA (High_Availability) Software is running on a system, do not use this subcommand
to reserve a disk on an SSA. Doing so could cause problems for the HA software.
-
set_boot_dev [-y] pathname
- Set the boot-device variable in the PROM to the physical device name specified by pathname which can be a block
special device or the pathname of the directory on which the boot file system is mounted. This subcommand normally runs interactively and requests confirmation for setting the default boot device in the PROM. The -y option can be used to run it in non-interactive mode,
in which case no confirmation is requested or required.
-
start [-t tray-number] pathname
- Spin up the specified disks. If pathname specifies the controller, this action applies to all disks in the SPARCstorage
Array.
- -t
- Spin up all disks in the tray specified by tray-number. pathname must specify the controller.
-
stop [-t tray-number] pathname
- Spin down the specified disks. If pathname specifies the controller, this action applies to all disks in the SPARCstorage
Array.
- -t
- Spin down all disks in the tray specified by tray-number. pathname must specify the controller.
-
sync_cache pathname
- Flush all outstanding writes for the specified disk from NVRAM to the media. If pathname specifies the controller, this action applies
to all disks in the SPARCstorage Array.
|
SCSI Enclosure Services (SES) Subcommands
|
The SPARCstorage RSM tray is addressed by the using the logical or physical path of the SES device or specifying the controller followed by the tray number if that controller has multiple trays. The controller is addressed by cN or the physical path to the SPARCstorage Array's controller.
See ses(7D) for more information about environmental sensor cards and associated devices.
These subcommands also work with RSM trays directly attached to wide differential SCSI controllers.
-
alarm pathname | controller tray-number
- Display the current state of the audible alarm.
-
alarm_on pathname | controller tray-number
-
alarm_off pathname | controller tray-number
- Enable or disable the audible alarm for this enclosure.
-
alarm_set pathname | controller tray-number [seconds]
- Set the audible alarm setting to seconds.
-
env_display pathname | controller tray-number
- Display the environmental information for the specified unit.
-
led pathname
- Display the current state of the led for the specified disk.
-
led_on pathname
-
led_off pathname
- Turn on or off the led for this disk.
-
power_off pathname | controller tray-number
- Power down this RSM. The RSM will need to be powered back
on manually.
This subcommand does not work with RSMs directly attached to wide differential SCSI controllers.
|
Expert Mode Subcommands
|
See NOTES for limitations of these subcommands. Only users that are knowledgeable about the systems they are managing should use the expert mode subcommands.
For the following subcommands that work on a bus if a disk is specified then the bus that disk attached to is used.
-
bus_getstate pathname
- Get and display the state of the specified bus.
-
bus_quiesce pathname
- Quiesce the specified bus.
-
bus_reset pathname
- Reset the specified bus.
-
bus_resetall pathname
- Reset the specified bus and all devices on that bus.
-
bus_unquiesce pathname
- Unquiesce the specified bus.
-
dev_getstate pathname
- Get the state (online or offline) of the specified device.
-
dev_reset pathname
- Reset the specified device.
-
offline pathname
- Turn the specified disk offline.
-
online pathname
- Turn the specified disk online.
|
|
| Example 1. Usingssaadm to remove a disk on an SSA
|
An example of using the expert mode hot plugging subcommands to hot remove a disk on a SSA follows. See NOTES for hot plugging limitations.
The first step reserves the SCSI device so that it can't be accessed via its second SCSI bus:
|
example# ssaadm reserve /dev/dsk/c1t8d0s2
|
The next two steps take the disk to be removed offline then quiesce the bus:
|
example# ssaadm -e offline /dev/dsk/c1t8d0s2
example# ssaadm -e bus_quiesce /dev/dsk/c1t8d0s2
|
The user then removes the disk and continues by unquiescing the bus, putting the disk back online, then releasing it:
|
example# ssaadm -e bus_unquiesce /dev/dsk/c1t8d0s2
example# ssaadm -e online /dev/dsk/c1t8d0s2
example# ssaadm release /dev/dsk/c1t8d0s2
|
|
|
|
The following exit values are returned:
-
0
- Successful completion.
- non-zero
- An error occurred.
|
|
See attributes(5) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Availability | SUNWssaop |
|
|
Currently, only some device drivers support hot plugging. If hot plugging is attempted on a disk or bus where it is not supported, an error message of the form:
|
ssaadm: can't acquire "PATHNAME": No such file or directory
|
is displayed.
Do not quiesce any bus containing a disk with the root, usr, or swap partitions to avoid possible system deadlock.
|
| |