|
System Administration Commands | projadd(1M) |
| projadd - administer a new project on the system |
SYNOPSIS
| projadd [-c comment] [-U user [,user ...] ] [-G group [,group ...] ] [-p projid [projid ...] ] project |
|
projadd adds a new project entry to the /etc/project file. If the files backend is being used for the project database, the new project is available for use immediately upon the completion of the projadd command.
|
|
The following options are supported:
- -c comment
- Add a project comment. Comments are stored in the project's entry in the /etc/project file. Generally, comments contain a short description of the project and are used as the field for
the project's full name.
Specify comment as a text string. comment cannot contain a colon (:) or NEWLINE.
- -G group
- Make group a member group of project.
Specify group as a group ID or name.
- -o
- Enable duplication of a project ID.
- -p projid
- Set the project ID of the new project.
Specify projid as a non-negative decimal integer below UID_MAX as defined in limits.h. projid defaults to the next available unique number above the highest number currently assigned. For example, if projids 100, 105, and 200 are assigned, the next default projid is 201. projids between 0-99 are reserved by SunOS.
- -U
- Add the existing users (as specified either by user ID or name), to member users of project.
|
|
The following operands are supported:
-
project
- The name of the project to create. The project operand is a string consisting of characters from the set of alphabetic characters, numeric characters, underline (_), and hyphen (-). The period ('.')
is reserved for projects with special meaning to the operating system. The first character of the project name must be a letter. A warning message is displayed if these restrictions are not met.
|
|
The following exit values are returned:
-
0
- Successful completion.
-
2
- The command syntax was invalid. A usage message for projadd is displayed.
-
3
- An invalid argument was provided to an option.
-
4
- The projid given with the -p option is already in use.
-
5
- The project files contain an error. See project(4).
-
6
- The project to be modified, group, or user does not exist.
-
9
- The project is already in use.
-
10
- Cannot update the /etc/project file.
|
|
-
/etc/project
- System project file
|
|
See attributes(5) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Availability | SUNWesu |
|
|
projects(1), groupadd(1M), groupdel(1M), groupmod(1M), grpchk(1m), projdel(1M), projmod(1M), useradd(1M), userdel(1M), usermod(1M), project(4), attributes(5)
|
|
In case of an error, projadd prints an error message and exits with a non-zero status.
projadd adds a project definition only on the local system. If a network name service such as NIS or LDAP is being used to supplement the local /etc/project file with additional entries, projadd cannot change information supplied by the
network name service.
|
| |