|
System Administration Commands | projmod(1M) |
| projmod - modify a project's information on the system |
SYNOPSIS
| projmod [-p projid [-o] [ -a | -r]] [-U user [,user ...] ] [-G group [,group ...] ] [-c comment] [-l new_projectname] project |
|
The projmod utility modifies a project's definition on the system. projmod changes the definition of the specified project and makes the appropriate project-related system file and file system changes.
|
|
The following options are supported:
- -c comment
- Specify comment as a text string. Generally, comment contains a short description of the project. This information is stored in the project's /etc/project entry.
- -G group [,group...]
- Specify a replacement list of member groups of the project, or with -a or -r, a list of groups to be added or removed from the project.
- -l new_projectname
- Specify the new project name for the project. The new_projectname argument is a string consisting of characters from the set of alphabetic characters, numeric characters,
period (.), underline (_), and hyphen (-). The first character should be alphabetic. A warning message is written if these restrictions are not met.
- -o
- This option allows the specified project ID to be duplicated (non-unique).
- -a
- This option specifies that the users or groups specified by the -U or -G flags should be added to the project, rather than replacing the existing member list.
- -r
- This option specifies that the users or groups specified by the -U or -G flags should be removed from the project, rather than replacing the existing member list.
- -p projid
- Specify a new project ID for the project. It must be a non-negative decimal integer less than MAXUID as defined in param.h.
- -U user [,user...]
- Specify a replacement list of member users of the project, or with -a or -r, a list of users to be added or removed from the project.
|
|
The following operands are supported:
-
project
- An existing project name to be modified.
|
|
In case of an error, projmod prints an error message and exits with one of the following values:
The following exit values are returned:
-
0
- Successful completion.
-
2
- The command syntax was invalid. A usage message for projmod is displayed.
-
3
- An invalid argument was provided to an option.
-
4
- The projid given with the -p option is already in use.
-
5
- The project files contain an error. See project(4).
-
6
- The project to be modified, group, or user does not exist.
-
9
- The project is already in use.
-
10
- Cannot update the /etc/project file.
|
|
-
/etc/group
- System file containing group definitions
-
/etc/project
- System project file
-
/etc/passwd
- System password file
-
/etc/shadow
- System file containing users' encrypted passwords and related information
|
|
See attributes(5) for descriptions of the following attributes:
ATTRIBUTE TYPE | ATTRIBUTE VALUE |
Availability | SUNWesu |
|
|
groupadd(1M), groupdel(1M), groupmod(1M), projadd(1M), projdel(1M), useradd(1M), userdel(1M), usermod(1M), passwd(4), project(4), attributes(5)
|
|
The projmod utility modifies project definitions only in the local /etc/project file. If a network name service such as NIS or LDAP is being used to supplement the local files with additional entries, projmod cannot change information supplied by the network name service. However projmod verifies the uniqueness of project name and project ID against the external name service.
|
| |